Call us today at 1 866 888-1CTI (1284).  

Innovator® SIP
SIP Voice Mail.

CommLink® Lite
Asterisk Freeware.

Innovator® Legacy
Legacy Voice Mail.

CommLink® Lite does not connect.
  • Confirm with network administrator that correct “Web URL Location” is specified in Network Configuration. After clicking “Test URL” button, you should get a message “Found a suitable connection…”
  • Confirm correct Voicemail Info is provided and that after clicking “Test Login” you get a message “Login successful”.
  • Confirm with network administrator that correct "Call Control/Screen Pop Info" is specified. After clicking "Test Login" button, you should get a message "Register successful!"
  • Check if Auto-Connect is On under CommLink® menu.
  • Invalid directories and/or permissions set on asterisk. Check directory where Asterisk records voicemails. By default it is set to /var/spool/asterisk/voicemail/default. This directory must exist in order to perform initial message synchronization. Otherwise, CommLink Lite will automatically disconnect.
  • Apache does not have permission to create directories and/or move files under /var/spool/asterisk/voicemail. CommLink Lite will automatically disconnect if it cannot perform these actions. Check to see if both apache and asterisk processes can run under same user -or- consider using a externnotify script. Refer to Server Setup Guides for your configuration under section Verify Asterisk and Apache are run as the same user.
CommLink® loses connection and does not reconnect.
  • Check if Auto-Connect is On under CommLink® menu.
No popups for incoming calls.
  • “Screen Pops Enabled” is selected in Options – Call Manager tab.
  • Check “Desktop Phone Extension” is correctly specified in Network Configuration. It needs to match the CallerID number of the ringing phone.
No audio notifications of new messages.
  • “Enable Announcement” is selected in Options – General.
  • Click Test button in Options – General to make sure that notification audio file is not correct.
Outdial not working.
  • Check “Desktop Phone Extension” is correctly specified in Network Configuration. The Desktop Phone Extension must match the phone expected to ring.
  • Check "Default Context" is correctly specified in Network Configuration. The "Default Context" must match the context for which the phone extension is assigned to.
Message notification via email does not include voicemail message as attachment.
  • “Include VM Attachment” is selected in Voicemail Properties.
In Call Manager, MSN list does not show contacts.
  • Phone is setup correctly and you’re receiving calls from other extensions.
  • Correct email of MSN contact is recorded in Outlook contact E-mail field.
In Call Manager, Accept button is not active on incoming calls.
  • Ensure that in CommLink® Network Configuration screen "Hands-Free Enabled" checkbox is selected and "Hands-Free Extension" is provided.
  • Check with Asterisk system administrator that a separate Hands-Free extension has been setup. Refer to back under section Adding Hands-Free/Intercom Configuration of Server Setup Guides for your configuration. You are required to create a separate extension for purposes of hands-free with SIPADDHEADER in asterisk extension configuration files.
Where are the log files?
  • Server-side logs where asterisk and apache processes are running the logs are located under /var/log/asterisk and /var/log/httpd.
  • Client-side run-time logs where Outlook, CommLink Lite for Outlook and Stand-Alone are located for Windows Vista is C:\Users\USERNAME\AppData\Local\CommLinkLite and Windows XP is C:\Documents and Settings\USERNAME\Local Settings\Application Data\CommLinkLite where USERNAME is the user account that is logged in.
  • Client-side INSTALL.LOG where CommLink Lite for Outlook and Stand-Alone are located "C:\Program Files\cloutlook Lite" and "C:\Program Files\CommLink Lite" respectively.
No toolbar for Commlink® in Outlook nor anyway to configure it after it is installed.
  • Is CommLink® listed in Outlook under menu Help -> Disabled Items or Help -> About and Disabled Items button?
  • Were there previous copies of any CommLink® products installed on the machine?
  • Was this installed by a user with local administrative privileges?
  • Was Outlook running during installation?
  • Has the machine been rebooted?
  • Is there any anti-virus or firewall software that monitors Outlook? If so, can Outlook be added to the exception list?
  • Try the following:
    • Turn off anti-virus, email scanners and firewall software.
    • Shutdown Outlook. Check Processes in task manager to be sure. End process if it is.
    • Use Task Manager to check Processes if COMMLI~1.EXE (CommLinkEventMonitor.exe) is running. End process if it is.
    • Uninstall CommLink® Lite for Outlook from the Add/Remove programs. Choose "Automatic" radio button then Next and "Yes to All" button for Remove Share Component.
    • Uninstall any CommLink® products if they are listed in the Add/Remove programs. Choose "Automatic" radio button then Next and "Yes to All" button for Remove Share Component.
    • Delete this directory if it exists, C:\Documents and Settings\USERNAME\Local Settings\Application Data\CommLinkLite or C:\Users\USERNAME\AppData\Local\CommLinkLite, where USERNAME is the user account that is logged in.
    • Delete this directory if it exists, C:\Program Files\cloutlook Lite\.
    • Delete any directories if they exist under C:\Program Files\ that have cloutlook or CommLink® directory names.
    • Reboot.
    • Turn off anti-virus, email scanners and firewall software.
    • Do not start Outlook. Leave it off. Check Processes in task manager to be sure. End process if it is.
    • Install full install of the CommLink® Lite for Outlook.
    • Reboot.
    • Turn off anti-virus, email scanners and firewall software.
    • Run Outlook and see if CommLink® toolbar appears.
    • Check if CommLink® listed in Outlook under menu Help -> Disabled Items or Help -> About and Disabled Items button. If it is then Enabled it.
"RunTime error '91': Object variable or with block variable" when Microsoft Office Display Language set to other than English.
  • RunTime error occurs when CommLink® toolbar loads in Outlook when Microsoft Office Display Language set to other than English. This is an issue at version 1.0.0.58 and earlier. Please download latest CommLink® Lite Outlook Add-In Installer -or- perform an Update from Programs > CommLink Lite for Outlook.